nitrokey-flake/flake.nix

16 lines
394 B
Nix

# vim: set noet sw=2 ts=2 sts=2:
{
description = "nitropy cli";
inputs.nixpkgs.url = github:NixOS/nixpkgs/nixos-23.05-small;
outputs = { self, nixpkgs }: rec {
nitropy =
# Notice the reference to nixpkgs here.
with import nixpkgs {
system = "x86_64-linux";
config.allowUnfree = true;
};
callPackage ./pynitrokey.nix { };
defaultPackage.x86_64-linux = nitropy;
};
}