35 lines
1.4 KiB
Diff
35 lines
1.4 KiB
Diff
Upstream: No (considered finished)
|
|
Reason: own `auto-str`, `hasshsgr.h` and `uint64.h`
|
|
Source: Daniel Mierswa <impulze@impulze.org>
|
|
|
|
--- ./src/Makefile.orig 2009-01-28 10:16:05.184974076 +0100
|
|
+++ ./src/Makefile 2009-01-28 10:17:18.306974606 +0100
|
|
@@ -163,16 +163,11 @@
|
|
hassgprm.h: choose compile hassgprm.h1 hassgprm.h2 load trysgprm.c
|
|
./choose cl trysgprm hassgprm.h1 hassgprm.h2 > hassgprm.h
|
|
|
|
-hasshsgr.h: chkshsgr choose compile hasshsgr.h1 hasshsgr.h2 load \
|
|
-tryshsgr.c warn-shsgr
|
|
- ./chkshsgr || ( cat warn-shsgr; exit 1 )
|
|
- ./choose clr tryshsgr hasshsgr.h1 hasshsgr.h2 > hasshsgr.h
|
|
-
|
|
haswaitp.h: choose compile haswaitp.h1 haswaitp.h2 load trywaitp.c
|
|
./choose cl trywaitp haswaitp.h1 haswaitp.h2 > haswaitp.h
|
|
|
|
iopause.h: choose compile iopause.h1 iopause.h2 load trypoll.c
|
|
- ./choose clr trypoll iopause.h1 iopause.h2 > iopause.h
|
|
+ ./choose cl trypoll iopause.h1 iopause.h2 > iopause.h
|
|
|
|
iopause.o: compile iopause.c iopause.h select.h tai.h taia.h uint64.h
|
|
./compile iopause.c
|
|
@@ -478,9 +473,6 @@
|
|
timestamp.o: compile tai.h taia.h timestamp.c timestamp.h uint64.h
|
|
./compile timestamp.c
|
|
|
|
-uint64.h: choose compile load tryulong64.c uint64.h1 uint64.h2
|
|
- ./choose clr tryulong64 uint64.h1 uint64.h2 > uint64.h
|
|
-
|
|
unix.a: alloc.o alloc_re.o buffer.o buffer_0.o buffer_1.o buffer_2.o \
|
|
buffer_get.o buffer_put.o buffer_read.o buffer_write.o coe.o env.o \
|
|
error.o error_str.o fd_copy.o fd_move.o fifo.o lock_ex.o lock_exnb.o \
|